Server Error
Incident Report for PGecom
Resolved
This incident has been resolved.
Posted Jan 31, 2022 - 09:27 UTC
Investigating
Our server was down on Friday 28th at around 9:00 pm EST and back up on Sunday at 1:00 am EST.
Posted Jan 31, 2022 - 09:26 UTC
This incident affected: Server.